re = /(?s)(.*?)\s*\(BlockID:\s*(\d+),TestCaseID:\s*(\d+)/
str = ' SomeText SomeText SomeText SomeText SomeText
SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText.
SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText.
SomeText SomeText :
SomeText SomeText SomeText SomeText SomeText SomeText (BlockID: 12345,TestCaseID: 12345, 1)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end