import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(.*?)\\s*\\(BlockID:\\s*(\\d+),TestCaseID:\\s*(\\d+)";
final String string = " SomeText SomeText SomeText SomeText SomeText \n"
+ "SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText.\n"
+ "SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText.\n"
+ "SomeText SomeText :\n"
+ "SomeText SomeText SomeText SomeText SomeText SomeText (BlockID: 12345,TestCaseID: 12345, 1)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}