#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\s*->\s*[\w.]+(\((?>'[^'\\]*(?:\\.[^'\\]*)*'|"[^"\\]*(?:\\.[^"\\]*)*"|[^"'()]++|(?1))*\)))+\s*\z"
Local $sString = "o.start_time = obj.s;" & @CRLF & _
"o.repair_type -> obj.r;" & @CRLF & _
"o.limit -> obj.l;->god("('\"\"')") ->fox(,'->')" & @CRLF & _
"->egg()->dog(,'c')" & @CRLF & _
"->cat(,'b')-> banana(,'a"\'\(\)\'->"()(') -> apple(,'a')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")