using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s*->\s*[\w.]+(\((?>'[^'\\]*(?:\\.[^'\\]*)*'|""[^""\\]*(?:\\.[^""\\]*)*""|[^""'()]++|(?1))*\)))+\s*\z";
string input = @"o.start_time = obj.s;
o.repair_type -> obj.r;
o.limit -> obj.l;->god(""('\""\""')"") ->fox(,'->')
->egg()->dog(,'c')
->cat(,'b')-> banana(,'a""\'\(\)\'->""()(') -> apple(,'a')";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}