use strict;
my $str = 'o.start_time = obj.s;
o.repair_type -> obj.r;
o.limit -> obj.l;->god("(\'\\"\\"\')") ->fox(,\'->\')
->egg()->dog(,\'c\')
->cat(,\'b\')-> banana(,\'a"\\\'\\(\\)\\\'->"()(\') -> apple(,\'a\')';
my $regex = qr/(?:\s*->\s*[\w.]+(\((?>'[^'\\]*(?:\\.[^'\\]*)*'|"[^"\\]*(?:\\.[^"\\]*)*"|[^"'()]++|(?1))*\)))+\s*\z/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}