#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)([\d.]+UAH)[\s\S]+(?=(4\*35))[\s\S]+\s(?(2)([\d.]+UAH))"
Local $sString = "100.00UAH Znyattya gotivki v bankomati WWWW, SSDSD" & @CRLF & _
"4*35 12:11" & @CRLF & _
"Bal. 1111.52UAH" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")