const regex = /([\d.]+UAH)[\s\S]+(?=(4\*35))[\s\S]+\s(?(2)([\d.]+UAH))/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d.]+UAH)[\\s\\S]+(?=(4\\*35))[\\s\\S]+\\s(?(2)([\\d.]+UAH))', 'gim')
const str = `100.00UAH Znyattya gotivki v bankomati WWWW, SSDSD
4*35 12:11
Bal. 1111.52UAH
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}