re = /([\d.]+UAH)[\s\S]+(?=(4\*35))[\s\S]+\s(?(2)([\d.]+UAH))/im
str = '100.00UAH Znyattya gotivki v bankomati WWWW, SSDSD
4*35 12:11
Bal. 1111.52UAH
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end