import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<ins>(?:[^<]+|<(?!br/|/ins))*)(?<my_br><br/>)(NL:)?((?:[^<]+|<(?!/ins))*</ins>)";
final String string = "<ins> <b>ABC</b> <br/></ins> <br/> \n\n"
+ "<ins><b>ABC</b></ins><br/><ins><b>ABC</b></ins>";
final String subst = "\\1\\2NL:\\4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}