import re
regex = re.compile(r"(<ins>(?:[^<]+|<(?!br/|/ins))*)(?<my_br><br/>)(NL:)?((?:[^<]+|<(?!/ins))*</ins>)")
test_str = ("<ins> <b>ABC</b> <br/></ins> <br/> \n\n"
"<ins><b>ABC</b></ins><br/><ins><b>ABC</b></ins>")
subst = "\\1\\2NL:\\4"
result = regex.sub(subst, test_str)
if result:
print(result)