const regex = new RegExp('(<ins>(?:[^<]+|<(?!br/|/ins))*)(?<my_br><br/>)(NL:)?((?:[^<]+|<(?!/ins))*</ins>)', 'g')
const str = `<ins> <b>ABC</b> <br/></ins> <br/>
<ins><b>ABC</b></ins><br/><ins><b>ABC</b></ins>`;
const subst = `\1\2NL:\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);