$re = '~(<ins>(?:[^<]+|<(?!br/|/ins))*)(?<my_br><br/>)(NL:)?((?:[^<]+|<(?!/ins))*</ins>)~';
$str = '<ins> <b>ABC</b> <br/></ins> <br/>
<ins><b>ABC</b></ins><br/><ins><b>ABC</b></ins>';
$subst = "\1\2NL:\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;