using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:Data|Field)(?!\h*$).+$";
string input = @"Data
Data
Datatest1
Data test
Data 867$33@!.//()7
Field somthing
Field ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}