import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Data|Field)(?!\\h*$).+$";
final String string = "Data \n"
+ "Data \n"
+ "Datatest1\n"
+ "Data test\n"
+ "Data 867$33@!.//()7\n"
+ "Field somthing\n"
+ "Field ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}