import re
regex = re.compile(r"(?:Data|Field)(?!\h*$).+$", flags=re.MULTILINE)
test_str = ("Data \n"
"Data \n"
"Datatest1\n"
"Data test\n"
"Data 867$33@!.//()7\n"
"Field somthing\n"
"Field ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")