using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id_(\w+)";
string input = @"http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}