$re = '/id_(\w+)/';
$str = 'http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);