const regex = /id_(\w+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('id_(\\w+)', '')
const str = `http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}