# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=<p>).*?(?=<\\/p>)/replace me/g;t' <<< "<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>"