import re
regex = re.compile(r"(?<=<p>).*?(?=<\/p>)")
test_str = ("<p>Hello !</p> <p>I wont select tags! Only text with in</p>\n"
"<p>Hello !</p> <p>I wont select tags! Only text with in</p>\n"
"<p>Hello !</p> <p>I wont select tags! Only text with in</p>\n"
"<p>Hello !</p> <p>I wont select tags! Only text with in</p>")
subst = "replace me"
result = regex.sub(subst, test_str)
if result:
print(result)