$re = '@(?<=<p>).*?(?=<\/p>)@';
$str = '<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>';
$subst = "replace me";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;