import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[Nn]issan(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\\n))*</(?:a|span)>)";
final String string = "Nissan\n"
+ "nissan\n"
+ "<span>Nissan</span>\n"
+ "<a href=\"nissan.com\">Nissan</a>\n"
+ "<a href=\"nissan.com\"><span>Nissan</span></a>\n"
+ "Company Nissan is a name. and Nissan Micra is model name. \n"
+ "Company <a href=\"nissan.com\"><span>Nissan</span></a> is a name. and Nissan Micra is model name. \n"
+ "This is new <a href='https://www.url.com'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>\n\n"
+ "<p>Company Nissan is a name Company Nissan is a name. Company Nissan is a name and <a href='www.nnm.be'><main>New Nissan Micra</main></a> is model name.</p>\n\n"
+ "<a>nissan </a>\n"
+ "<a>nissan\n"
+ "</a>\n\n"
+ "<a>nissan<span></span><a>\n"
+ "<a foo=\"nissan\" bar=\"<\">text<a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}