re = /[Nn]issan(?=[^<>]*<)(?!(?:(?!<\/?(?:a|span)[ >\/])(?:.|\n))*<\/(?:a|span)>)/
str = 'Nissan
nissan
<span>Nissan</span>
<a href="nissan.com">Nissan</a>
<a href="nissan.com"><span>Nissan</span></a>
Company Nissan is a name. and Nissan Micra is model name.
Company <a href="nissan.com"><span>Nissan</span></a> is a name. and Nissan Micra is model name.
This is new <a href=\'https://www.url.com\'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>
<p>Company Nissan is a name Company Nissan is a name. Company Nissan is a name and <a href=\'www.nnm.be\'><main>New Nissan Micra</main></a> is model name.</p>
<a>nissan </a>
<a>nissan
</a>
<a>nissan<span></span><a>
<a foo="nissan" bar="<">text<a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end