import Foundation
let pattern = #"[Nn]issan(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\n))*</(?:a|span)>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Nissan
nissan
<span>Nissan</span>
<a href="nissan.com">Nissan</a>
<a href="nissan.com"><span>Nissan</span></a>
Company Nissan is a name. and Nissan Micra is model name.
Company <a href="nissan.com"><span>Nissan</span></a> is a name. and Nissan Micra is model name.
This is new <a href='https://www.url.com'><span>URL</span></a>.<br /> Company Nissan is a name. and Nissan Micra is model name. </p>
<p>Company Nissan is a name Company Nissan is a name. Company Nissan is a name and <a href='www.nnm.be'><main>New Nissan Micra</main></a> is model name.</p>
<a>nissan </a>
<a>nissan
</a>
<a>nissan<span></span><a>
<a foo="nissan" bar="<">text<a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)