using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^image/(?:gif|p?jpeg|(?:x-)?png)$";
string input = @"image/bmp
image/gif
image/png
image/jpg
image/jpeg";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}