// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^image/(?:gif|p?jpeg|(?:x-)?png)$").unwrap();
let string = "image/bmp
image/gif
image/png
image/jpg
image/jpeg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}