package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^image/(?:gif|p?jpeg|(?:x-)?png)$`)
var str = `image/bmp
image/gif
image/png
image/jpg
image/jpeg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}