$re = '~^image/(?:gif|p?jpeg|(?:x-)?png)$~im';
$str = 'image/bmp
image/gif
image/png
image/jpg
image/jpeg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);