using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!--).*(\{![^!]*!\})";
string input = @"-- Here is some comment {!0-goal!}
{!1-goal!}
Here is some text and {!3-goal!}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}