re = /^(?!--).*(\{![^!]*!\})/m
str = '-- Here is some comment {!0-goal!}
{!1-goal!}
Here is some text and {!3-goal!}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end