const regex = /^(?!--).*(\{![^!]*!\})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!--).*(\\{![^!]*!\\})', 'gm')
const str = `-- Here is some comment {!0-goal!}
{!1-goal!}
Here is some text and {!3-goal!}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}