$re = '/^(?!--).*(\{![^!]*!\})/m';
$str = '-- Here is some comment {!0-goal!}
{!1-goal!}
Here is some text and {!3-goal!}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);