using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\((.*?)\)(.*?)\]";
string input = @"'[(id,name,top,left,width,height,depth)filename][(id,name,top,left,width,height,depth)filename]'";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}