re = /\[\((.*?)\)(.*?)\]/
str = '\'[(id,name,top,left,width,height,depth)filename][(id,name,top,left,width,height,depth)filename]\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end