package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\[\((.*?)\)(.*?)\]`)
var str = `'[(id,name,top,left,width,height,depth)filename][(id,name,top,left,width,height,depth)filename]'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}