package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div class=\"progressnumber\".*?>(.*)<\/div>`)
var str = `<div class="progressnumber">20%</div>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}