const regex = /<div class=\"progressnumber\".*?>(.*)<\/div>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class=\\"progressnumber\\".*?>(.*)<\\\/div>', '')
const str = `<div class="progressnumber">20%</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}