$re = '/<div class=\"progressnumber\".*?>(.*)<\/div>/';
$str = '<div class="progressnumber">20%</div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);