re = /<div class=\"progressnumber\".*?>(.*)<\/div>/
str = '<div class="progressnumber">20%</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end