use strict;
my $str = 'countsfrom=2016-07-20T12:46:49%2B03:00&instrument=1&levels=1&levels=2&levels=3&to=2016-07-21T12:46:49%2B03:00';
my $regex = qr/"(?<=/countsfrom=)(.*)(?=&instrument=1&levels=1&levels=2&levels=3&to=)(.*)"/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}