re = /"(?<=\/countsfrom=)(.*)(?=&instrument=1&levels=1&levels=2&levels=3&to=)(.*)"/
str = 'countsfrom=2016-07-20T12:46:49%2B03:00&instrument=1&levels=1&levels=2&levels=3&to=2016-07-21T12:46:49%2B03:00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end