$re = '/"(?<=/countsfrom=)(.*)(?=&instrument=1&levels=1&levels=2&levels=3&to=)(.*)"/s';
$str = 'countsfrom=2016-07-20T12:46:49%2B03:00&instrument=1&levels=1&levels=2&levels=3&to=2016-07-21T12:46:49%2B03:00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);