import re
regex = re.compile(r"\"(?<=/countsfrom=)(.*)(?=&instrument=1&levels=1&levels=2&levels=3&to=)(.*)\"", flags=re.DOTALL)
test_str = "countsfrom=2016-07-20T12:46:49%2B03:00&instrument=1&levels=1&levels=2&levels=3&to=2016-07-21T12:46:49%2B03:00"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")