#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)sum\((?:\([^()]*\)|.)*?\)"
Local $sString = "str1 = eval(sum(feat(57),feat(57),feat(66))/feat(57));" & @CRLF & _
"str2 = eval(sum(feat(47),feat(55),feat(86)));" & @CRLF & _
"str3 = eval(feat(47)/sum(feat(51),feat(52),feat(53)));" & @CRLF & _
"str4 = eval(feat(63)/sum(feat(57):feat(66)));"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")