re = /sum\((?:\([^()]*\)|.)*?\)/m
str = 'str1 = eval(sum(feat(57),feat(57),feat(66))/feat(57));
str2 = eval(sum(feat(47),feat(55),feat(86)));
str3 = eval(feat(47)/sum(feat(51),feat(52),feat(53)));
str4 = eval(feat(63)/sum(feat(57):feat(66)));'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end