import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "sum\\((?:\\([^()]*\\)|.)*?\\)";
final String string = "str1 = eval(sum(feat(57),feat(57),feat(66))/feat(57));\n"
+ "str2 = eval(sum(feat(47),feat(55),feat(86)));\n"
+ "str3 = eval(feat(47)/sum(feat(51),feat(52),feat(53)));\n"
+ "str4 = eval(feat(63)/sum(feat(57):feat(66)));";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}