import re
regex = re.compile(r"sum\((?:\([^()]*\)|.)*?\)", flags=re.MULTILINE)
test_str = ("str1 = eval(sum(feat(57),feat(57),feat(66))/feat(57));\n"
"str2 = eval(sum(feat(47),feat(55),feat(86)));\n"
"str3 = eval(feat(47)/sum(feat(51),feat(52),feat(53)));\n"
"str4 = eval(feat(63)/sum(feat(57):feat(66)));")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")