#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[tT="](?!0{1,3}$)[0-9]{1,3}$"
Local $sString = "T="100" & @CRLF & _
"T789" & @CRLF & _
"T001" & @CRLF & _
"T000" & @CRLF & _
"t00" & @CRLF & _
"t012" & @CRLF & _
"t000" & @CRLF & _
"t0" & @CRLF & _
"t" & @CRLF & _
"t1231" & @CRLF & _
"" & @CRLF & _
"a456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")