import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[tT=\"](?!0{1,3}$)[0-9]{1,3}$";
final String string = "T=\"100\n"
+ "T789\n"
+ "T001\n"
+ "T000\n"
+ "t00\n"
+ "t012\n"
+ "t000\n"
+ "t0\n"
+ "t\n"
+ "t1231\n\n"
+ "a456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}