import re
regex = re.compile(r"^[tT=\"](?!0{1,3}$)[0-9]{1,3}$", flags=re.MULTILINE)
test_str = ("T=\"100\n"
"T789\n"
"T001\n"
"T000\n"
"t00\n"
"t012\n"
"t000\n"
"t0\n"
"t\n"
"t1231\n\n"
"a456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")